
Improved sorting and filtering in Excel 2007 
  

There are powerful new features in Excel 2007 to help you analyze and communicate 
business information and share it with other people. You can quickly arrange your worksheet 
data to find the answers that you need by using enhanced filtering and sorting. For example, 
you can now sort data by color and by more than 3 (and up to 64) levels. 
  
Here are some useful, free learning resource on data sorting and filtering:  

 Overview of Excel Tables 
 Pivot Tables in Excel 2007 

  

Excel 2007 Tables 
Excel 2007 introduced a new concept of working with tables of data. This new functionality is called 
"Tables". Tables in Excel 2007 are the successor of Excel 2003's "List" feature, with added 
functionality. 
 
If you already have some data available somewhere on a sheet, it is easy to create a table.  
Download this file: http://www.cob.sjsu.edu/kwan_p/91L/BPTDATA.xlsx onto your desktop and 
open it; select the DataSet worksheet. 

 

Let‟s create an Excel Table: 

1. Cell range $A$2:$K$302 is the data for the table. Select any cell in this range. 
2. Insert -> Table; then select $A$2:$K$302, and check “My table has headers”. 
3. You now see a downward arrow next to each of the “heading” in Row 1.  

Pull down on each of these downward arrows and see what choices you have. 
 

Sorting 
We’ve already come across sorting before. 
  
Let‟s do the following together: 

http://office.microsoft.com/en-us/excel/HA100485461033.aspx
http://www.homeandlearn.co.uk/excel2007/excel2007s7p7.html
http://www.cob.sjsu.edu/kwan_p/91L/BPTDATA.xlsx


1. Sort by Major – Pull down the downward arrow in D2 and select „Sort A to Z‟.  
2. Sort by Class – Pull down the downward arrow in E2 and select „Sort Z to A‟. 
3. Sort by last name, then by first name –  

a. Select any cell in the table. 
b. Data -> Sort & Filter -> Sort. 
c. In the Sort dialog box, set the “Sort by” option to last name, and “Order” option 

to A to Z. 
d. Click on “Add level”. 
e. Set the “Then by” option to first name, and “Order” option to A to Z. 
f. Click OK.  

 

Filtering 

Filtering is a method of finding certain records in a spreadsheet based on any criteria you 
choose. 
In addition, filtering enables you to hide records that don't meet your criteria, displaying just a 
subset of data. 

Using the same DataSet worksheet, let‟s do the following filtering actions together: 

1. Insert -> Table; then select $A$2:$K302, and check “My table has headers”. 
You now see a downward arrow next to each of the “heading” in Row 1. 
 

2. Filter for Finance majors – Click the downward arrow in D2. Click on (Select All) 
to de-select everything, then click on Finance, and Click the OK button. Now 
you see records (rows) of only those who are Finance majors. 
 

3. Remove filter from “Major” – Click on the „Clear Filter from “Major”‟ and we‟re 
back to how things were. 
  

4. Filter for Seniors – Click the downward arrow in E2. Click on (Select All) to de-
select everything, then click on Senior, and Click the OK button. Now you see 
records (rows) of only those who are Seniors in Class standing. 
 

5. Filter for those whose last name contains „ar‟ – Click the downward arrow in B2. 
Click on (Select All) to de-select everything, then click on Text Filters -> 
Contains. In the Custom AutoFilter dialog box, type in „ar‟ as shown in the 
picture below. Click the OK button. Now you see records (rows) of only those 
whose last name contains „ar‟. 
 

6. Filter by Color – Note that we also have an option to filter by colors in the cells. 
Let‟s put yellow background to B10, B22, and B26. How do you think you can 
set a filter to Column B (Last Name) and get only these 3 rows (records) after 
filtering? 

 
 

Advanced Filter 
 

You may have noticed there is an icon called “Advanced Filter” in the Sort & Filter group 



under the Data tab. With Advanced Filter, we can multiple criteria in data selection – 
selecting data if all of several criteria are met, or if one of several criteria is met. Let’s figure 
this out by means of an example. 
 

 
O P Q R 

2 Major Class Gas Phone 

3 International Business Senior >=50   

4 International Business Senior   >40 

 

 

Using the same DataSet worksheet, we will now see how we can find the 
students who are seniors majoring in Internal Business, and either spends 
$50 or more on gasoline, or more than $40 on phone bills. 
1. Select the headers: „Major‟ (D2), „Class‟ (E2), „Gasoline‟ (G2), and 
„Phone‟ (H2). 
2. Copy them. 
3. Paste the headers to Cells O1:R1. 
4. Now write the criteria under the header according to your decision to extract certain 
data: 

a. 'International Business' in Cell O2 and Cell O3 under „Major‟ header (O1); 
b. „Senior‟ in Cell P2 and Cell P3 under „Class‟ header (P1); 
c. „>=50‟ in Cell Q2 under „Gas‟ header (Q1); 
d. „>40‟ in Cell R2 under „Phone‟ header (R1). 

5. Now click anywhere inside the data range (A2:K302) 
6. Then click on the 'Data' tab, and under the group 'sort & filter' select 'Advanced' 
 

A new pop-up window with the title 'Advanced Filter' appears and the list range is automatically 

selected. 

 

7. Select „Copy to another location‟. 
8. In the textbox next to the 'criteria range', you can either enter the range manually or 
select the range O1:R3. 
9. In the textbox next to the „Copy to‟ you can either enter O5, or select 
the cell O5. (This is so that you leave an empty row between the filter criteria 
and the filtered results.) 
10. Finally, click 'OK'. Now you observe that your data has been filtered according to 
your specified conditions, and displayed in a cell range starting with O6. 
 
NOTE: Placing two or more criteria directly underneath an applicable heading is to 
specify an OR condition. 
Copying a column heading twice side by side, and specifying a criterion under each of 
the headings is to specify an AND condition. 
 
For example, this below criteria means to select students who are Juniors, who either major 
in Finance or Marketing, and have spent more than $50 but less than $75 in phone bills. 
 

Major Class Phone Phone 
Finance Junior >50 <75 
Marketing Junior >50 <75 

 



You may want to view this link for more information on Advanced Filter. 
 

Adding Subtotals to the Sorted Table 
  
NOTE: The Subtotal command is not available for Excel Tables. To find subtotals for Table 

data, you can convert it to a normal data range and then perform the ` command.  
To convert a table to a data range: 
 

1. Select a cell within the Table 

2. Design -> Tools group ->CONVERT TO RANGE  
3. In the confirmation dialog box, click YES. The Table is converted to a range.  

 
 

It is easy to group records in a sorted table, and see statistics (e.g. subtotals) for each group. 
  
Following the same DataSet worksheet, let‟s try the following: 

1. Click in column F and sort the data in the table in alphabetical order by Major, 
using the A-Z icon.  

2. Click in any cell in the data range.  
3. Now click Data -> Outline -> Subtotal. 
4. In the dialog box, “At each change in” select Major; “Use Function” is Sum (or 

you can choose Average or Count as desired); and select „Gas‟, „Phone‟, 
„Music‟, „Clothes‟ and „Food‟ under “Add subtotal to”.   

5. Of the three checkboxes below, select “Replace current subtotals” and 
“Summary below data.”  

6. Click OK.  
7. Your report will now include subtotals. Scroll down to see them. 
8. Click on a minus sign (or click Data->Outline->Hide Detail) to hide the individual 

names and details.  
9. Click on a plus sign (or click Data->Outline->Show Detail) to show the names 

and details.  
 

To remove Subtotal: 
1. Click in the table.  
2. Now click Data -> Outline -> Subtotal. 
3. In the dialog box, click on “Remove All.”  

 

 

Using Pivot Tables to Organize Data 
 

Pivot tables are a feature that you should learn how to use. Instead of analyzing rows and 
rows of records, a pivot table can organize and aggregate your data and show a new 
perspective or view with few clicks. You can also move columns to rows or vice versa.  
  
Many people believe creating a pivot table is too difficult to learn. It is not very difficult. Let’s 
try some simple pivot table techniques together.  

http://office.microsoft.com/en-us/excel-help/filter-by-using-advanced-criteria-HP005200178.aspx


What is a Pivot Table? 
Think of a pivot table as a summary table of your original spreadsheet. You create the table 
by specifying which fields (based on headings) to display and how the data for those fields 
should be displayed. Based on your field selections, Excel aggregates and organizes the 
data so you see a different view of your data. 
  
Let’s continue to use the DataSet worksheet to explore Pivot Table creation.  
Using pivot tables, you can organize and group the same data in ways that start to answer 
questions such as: 

 What can I tell about the Phone, Music, Clothes and Food spending habits of people 
by their Major? 

 How about differences in spending behavior depending class standing (senior, junior, 
sophomore, and freshmen)? 

 Do people spend more on clothes than food? 

 Do people spend more on music or phone? 

 etc. 

Let‟s do this together! 

1. Insert -> Tables -> Pivot Table -> Pivot Table 

2. Fill in the Create PivotTable dialog box as shown in picture below. Click OK. 
3. On a new sheet, you will see Pivot Table1 (this number may be 1, 2, 3, etc.) 

depending on how many pivot tables you have created. You also see the 
PivotTable Field List on the right hand side. 

4. Now, drag Major to the Report Filter box. 
5. Next, drag M/F to the Report Labels box (below Major). 
6. Next, drag Class to the Row Labels box. 
7. Then drag the following to the Values box: Phone, Music, Clothes, and Food. 
8. As you do this, you see a table appearing on the left! Click in any cell outside 

of PivotTable Field List area and you‟re done! 
 



 
Now, let‟s answer these questions: 

1. What is the total phone bill for ALL Freshmen who are Accounting majors? 

 Pull down on B1 and select Accounting; and B2 should be (All) for both 
male and female people. 

2. What is the spending on Clothes for all Female students in any major? 

 B1 should be (All) for all majors; pull down on B2 and select F for Female. 
3. What is the average spending on Music by Seniors who are Finance majors? 

 B1 should be (All) for all majors; and B2 should be (All) for both male and 
female people. 

 Click on C5, and give to the right-hand side where the PivotTable Field 
List is shown.  

 Click on the downward triangle next to Summary of Music, and select 
Value Field Settings… to change it to Average. Now click away from 
PivotTable Field List. 

 

Data Forms 
If your spreadsheet is too big to manage, and you constantly have to scroll back and forward 
just to enter data, then a Data Form can make life easier. A Data Form is just a way to 
quickly enter data into cells. It is used when the spreadsheet is too big for the screen.  
  
First, using the same DataSet worksheet, let‟s create a data form. 

 Pull on the down arrow next to the Quick Access toolbar. Select More 
Commands… 

 Inside the Excel Options dialog box, under “Choose commands from:” select 
“All Commands”. Now look for “Form” and click the “Add >>” button in the 
middle to put it into the “Customize Quick Access Toolbar” side. Click OK. 



 Adding a new record into the table 

 Click on any cell in the table and click on the Form icon. 

 Click New. 

 Create a new record using your personal data. Use the Tab key to move 
between fields. The ID# will be 401. Expenses will be $55 for each 
category. 

 Click Close to complete adding your record to the data table. 

 Find and edit a record in the table 

 Click on any cell in the data table and click on the Form icon. 

 Click on Criteria. 

 Enter 106 for the ID#. 

 Click Find Next. 

 Change the student‟s class to Sophomore. 

 Click close to effect the change to the record. 

 


